Hello - What type of naming convention do you use for plugins? I think that class *library* names should map to entity names. I think that the specific classes that are registered should correspond to the basic action for which they are registered.
For example, if a class is used for pre-save then the class should be named PreSave. If a class is used for post-save then the class should be named PostSave. This should provide the entry point into the class and then specific business rules should be delegated into specialized methods within the class or delegated into other specialized classes via the primary PreSave/PostSave plugin class.
Do you agree or do you have a different opinion?